Issue with joining lobbys

I have a little problem with joining lobby servers.

When I am in a server, I can’t do anything. I can’t even close the game.

I’ve added a picture of what I see when I join a server.

Do you guys know what the problem could be?

My steam name is the_max99 if there could be something wrong in the database.

(somehow, I can still play minigames though)

Try to re-install the game, or restart your computer. Hopefully it’ll help.

I used to have this problem too, actually. Used to happen quite a bit.

I can’t remember exactly how I solved it, but I just forced the game to shut down through the task manager and checked if the game was up to date, and joined again. It seemed to fix itself over a day or so.

I still see this when i load Tower Unite but only the first time i load it after i restart my PC. It’s just loading everything in and should eventually join the lobby. I have a i7 3770k a GTX970 and 16gb ram and i still wait around 10-15 seconds for this screen to go. Possibly to do with the fact i have a HDD not SSD so this will make load times longer too.

Thx for your help but neither of those options work.

I finaly found out what the problem is…

My friend once tried to cheat in Tower Unite on my computer WITHOUT my permission and now I have a VAC ban! I have no idea how I can fix it but what I do know is that I probably can’t play Tower unite ever again… :frowning:

That’s uh… not a very nice friend you got there. Sad to say but the VAC ban won’t be removed from Valve, they never do that. The only times they did was when some games caused a false-positive.

1 Like