Internet content doesn't load


So it’s been a bit since I’ve played, came back today and it seems internet content doesn’t want to load?

As soon as I started up the game I was greeted with these lovely patch notes

I loaded into my condo and after doing some editing tried to watch some videos in-game, but the video content doesn’t load. The video title and length load, and if I turn off the screen a thumbnail will load, but in-game the screen will stay black. It plays fine in Edge and in the Steam Browser, but not in TU.

Now while I was testing and taking screenshots, this particular video did load, after it sat there for 2 and a half minutes. Suddenly the loading animation appeared and then the video started playing at the beginning (despite what the video player said). Scrolling the control back to 0 seconds and letting it play, this video then did work fine and matched the player controls.

However as soon as I gave it a different YouTube video and hit skip, we were back to square 1. I waited the entire duration of the video and it did not load.

After this I hit Disconnect and connected to a Plaza (Official US Chicago in this case) and the signs right as you get dropped off by the subway didn’t load.

Just tried with a soundcloud link and it does the same thing youtube does.

And for the sake of testing, I grabbed one of these screenshots and threw it into a canvas, and it actually loaded fine.

Things I’ve tried:

  • Rebooted Modem
  • Rebooted Router
  • Restarted game (game hangs on close so I have to terminate Steam…)
  • Restarted Steam
  • PC: Turned it off and on again
  • Verified Game Cache
  • Changed DNS Providers (Was GoogleDNS, now CloudFlare DNS)
  • Manually added game .exes to Windows Firewall
  • Opted out of the Steam Client Beta (Troubleshooting based on this post: Videos are not loading properly)


+1 being a fan of Monstercat :ok_hand:


Are you perhaps blocking


I am not, and even tried adding exclusions to Malwarebytes and even turning it off. is also not blocked in my hosts file.

Then I tried tracert and it looks like the connection dies about 6 jumps after it leaves my house :confused:

Then I remembered yesterday I also couldn’t connect to Looking both up on the hosting provider for both is listed as DreamHost, and sure enough if I ping both of them, they are in the same block, and the tracert is identical.

So I guess either DreamHost has blocked my IP for some reason (yay dynamic IPs), or there’s a bad node on the route and I can’t access it for now. Testing towerunite from my phone, I can’t connect on WiFi, but on Verizon’s network I can connect.

Either way, I don’t think there’s much that can be done, save for either hopping on a VPN or waiting for it to clear up.


Well to round this out, I hopped on ProtonVPN and sure enough everything loads fine now (albeit a bit slower than normal, but that’s a free VPN for ya). So I guess I’ll just have to deal with it for now, and maybe this thread will help someone else experiencing the same thing.


That’s really odd… why should you have to hop on a VPN in order to receive the streaming content? And why did it only just start happening?


If his VPN is blocking, then the patch notes and update banner won’t function as they are hosted on our website.


No I have to hop on a VPN to see the content, when I’m not on the VPN the content doesn’t load.


So my suspicions are pretty much confirmed IMO. A friend invited me to play Tabletop Simulator, and when our group’s game eventually concluded I was greeted with this lovely message in chat:

I had wondered why Global chat didn’t load when I started, but didn’t think much of it as we went pretty much straight into the game, and my game was loading slow (lots of workshop updates when you haven’t played in over a month lol).

What I’ve figured out from the resulting page is that Geekshed’s IRC network uses 3-day bans that auto-refresh if you connect to the server before the ban is up. (If there’s 5 minutes left and you reconnect before the 3-day ban is up, the timer gets reset to 3 days.)

I hopped into my modem and found this lovely bit of information:

At some point my ISP switched to 15 minute leases, and I’m pretty sure it used to be 7day+. So likely what happened is on the 17th or 18th during one of those 15 minute windows my IP changed. And because it’s dynamic @ 15 minute intervals there are 96 chances every day that my IP might change.

Which is especially fun because sometimes I’ll have the same IP for months on end, and sometimes it changes quite frequently. I’ve tried a few times to release/renew and get a different IP, but at 4am on a Saturday it’s not likely to change unless it happens automatically and I get the timings right.

So maybe I’ll care enough at some point this week to actually try by keeping my modem disconnected for an extended time. Most likely I’ll just let it stay and naturally change like it has done in the past. So far I’ve only discovered 2 networks (DreamHost and GeekShed) that the previous person got banned from, so it’s fairly bearable, and just an annoyance more than anything.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.