I can't change my accessories

The titel says everythingh

Could you explain in a little more detail?

Are you on the main menu when you are trying to change your appearance or in a lobby/condo?
Are you trying to buy accessories or just put on ones you already have?

Edit: If you are trying to buy accessories and they aren’t appearing, that’s a steam issue. Just wait and they will appear.

I tried to change it everywhere on official servers inofficial condo and main menu doesnt works still not. And im trying to change which i already have (btw in minigolf i cant change my hat too)

That’s weird, you’ll have to wait for a dev to see this I guess.

Edit: Fixed the title.

i srsly need help because its annoying to have some nice hats and expensive effects but you cant use them

Alright here is how to accdess your appearence.


  1. Press Esc
  2. Click on appearence
  3. Customize your character

(From start menu)

  1. Click on appearence
  2. Customize your character

i already know that but i cant press on the accesories and change them

You need Units to unlock them so that you can use them, say you want to own the aviator sunglasses, that will cost you 800 Units unlock them.

Dude i was able to change them but after a update (idk which) i couldnt change them anymore (and i boughed them)

Then i would say contact the pixeltail developers right now because that sounds like a serious bug.

yep it is rly annoying but i can still play the game so i just made this Report now