Game will not recognize things for some reason

When I logged in today, my game said I was “Player” with 0 Units. I looked at my appearance menu, and I still had everything I had when I last played, and when I looked in my inventory, I still had all my items. It just doesn’t recognize my name or my units, and when I tried to connect to a server, no listings ever come up. Idk what I did or what this thing is or what it means. Could someone please explain this to me or help me with this?

Please make sure that you are connected to Steam, and do not have multiple copies of the game running in the background.

I am connected to Steam, yet when I try and quit the game, Steam still says I’m running the game in the background, even though I quit it.

You need to check your task manager and make sure it’s dead.

1 Like

I keep trying it, and it still says “Player, 0 Units”. Plus, whenever I quit the game, Steam still says the game is running.

Check the “processes” tab of Task Manager; if Steam says it’s still running, you should find a process named something like “Tower-Win64-Shipping.exe.” Just end the process, and things should be fine.

If the problem persists, it might be a port problem. I’d recommend making sure all of these ports are portforwarded:

Guys, I have no idea how to fix this. Everytime I launch the game, I still can’t do anything. What do I do? ;-;

The 0 Units issue will occur when you are running a copy of the game in the background (check task manager) and / or Steam is down for maintenance or just down in general.

When I check Task Manager, it says I only have one copy of the game running, and same thing with Steam.

Maybe restart steam?

Tried that. Didn’t work.

Daaaammmn that really sucks :fearful:

And you checked the ports already as well?

Restart your computer and try it again.