Deformed model stuck on the floor, help


Hello, I am trying to import a model into Tower Unite, but the character becomes like this when I import it. I have deleted some materials and bones, cause there were more of them than Tower Unite would allow there to be. (22 Materials and 71 Bones total in the original model.)

Here is a picture of the original model with bones (Amelia Watson created by lexferreira89 on Sketchfab):

I don’t know what bones or materials I can delete and still keep the model working properly. Or is there a way I should modify them? Keep in mind, this is my first time using Blender or any 3d modeling program at all so I don’t know much about the program.

If this message made any sense and you understood my problem, I would be very grateful for help :D.

1 Like

To import a player model into the game, the model must be rigged to the official Tower Unite Workshop Rig, which is available here:

An official tutorial on rigging already-rigged models to the Tower Unite skeleton can be found here:

Note that:

  • This tutorial uses an outdated version of Blender (2.79), and that Blender’s UI has changed significantly since version 2.8, but the general instructions should be the same.
  • The beginning of this tutorial is specifically aimed toward importing models from the Source engine. Crowbar does not need to be used or downloaded, just that the “TowerUniteWorkshop_rig.blend” file should be opened first, and your desired model should then be imported into that .blend file. Importing the model into an empty file and then importing in the Tower Unite rig will result in unit scale issues that will prevent the model from importing properly (although this is fixable).
  • The tutorial has one critical error and some drag-and-drop actions that seem to no longer exist in later Blender versions, which are located at around 16:33 in the video. Instead of dragging and dropping to parent the mesh (model) to the armature (skeleton), you will want to select the mesh first, then shift-click to select the armature second, and then press CTRL-P to open the “Set Parent To” menu. Then, under the dropdown, instead of selecting “With Envelope Weights”, you want to select “Armature Deform”. Using a sub-option under the “Armature Deform” section will clear the existing weights and (depending on the selected option) auto-generate weights, which won’t be desirable for models that are already rigged.