Crash when trying to customize appearance

Whenever I try to customize my appearance in the alpha it crashes and says “Video driver crashed and was reset! Make sure your video drivers are up to date. Exiting…” Does anyone know what the problem is and how I might fix it?

Well the most obvious thing to do it to check if your drivers are up to date, I honestly wouldn’t know what to do if that doesn’t work.

Mine does the same thing. Do you happen to have an Intel® HD Graphics 4000 Graphics Card?

By the way, try using the customize character button from the pause menu while inside Plaza or Condo, that worked fine for me.

Yeah I discovered that as well however I also found it crashed when I picked up a unit in the ball race game. I have an Intel card yes and I’m using an Asus. I tried to check their website for a driver update but unfortunately couldn’t find one.

Yup, looks like we’re in the same boat man. I looked all day yesterday trying to find an update for my Intel Card for my Dell laptop. Mine crashes with the units in ball race, character customization from main menu, and when I press E on the magical potion. Do you also get weird textures at the boardwalk?

What do you mean by weird textures. I don’t think I do though maybe it’s something to do with the graphical settings. Mine are on low.

This is what my game looks like when I’m at the boardwalk:

Nope, I’m not getting that.

Here’s what we recommend on the FAQ:

Desktop PC or Mac
Windows 7 64-bit or Mac OS X 10.9.2 or later
Quad-core Intel or AMD processor, 2.5 GHz or faster
NVIDIA GeForce 470 GTX or AMD Radeon 6870 HD series card or higher

It doesn’t seem like UE4 supports Intel graphics cards, so that’s the problem.