Cannot see a PixelTail Lobby/Had to create new account for forums

My game has not been able to show an Official PixelTail Lobby for about a week now, I also had to create a new account just to log in to Forums through Steam. Is anyone else having this issue? If so, how do I fix this? With Poker coming up in the future, I will be very upset if I cannot connect to the Official PixelTail Lobby Server.

Here’s some of the routine checks for problems like these:

  • Are you properly connected to Steam?
  • Is Steam up?
  • Is there another instance of Tower Unite running?

For the last one, if you don’t restart your computer/laptop very often, it could happen that there’s a Tower Unite process still running, and it’s messing with the one that you’re trying to play on.

If none of these are the case, then some more information is going to be needed.

If none of these steps work, make sure these ports are opened found here:

Yes, I am properly connected to steam, Yes, steam is up, Only one Tower Unite is running, Yes, I restart every day. I even tried to join Official Server by;

  1. Trying to join a friend already in Official server.
  2. Trying to join by exiting my condo door.
  3. Waiting to see if it will auto-join me after a gamemode
  4. In Task-Manager there is only one Tower Unite running, no other process still running.

I haven’t tried un-installing the game and reinstalling yet. I’ll try that.

Thank-you for your advice, It is helpful.

I will make sure those ports are open. Thank-you for the advice. It is helpful.

Thank-You to whoever did whatever magic they did! I can now get into the Official PixelTail Plaza Server. Much appreciated! :smile:

1 Like