[0.9.0.0] Fatal Error at start

I tried everything. Validating files, deleting workshop cache, running in DirectX 10 mode, deleting the Local AppData, -useallavailablecores -fullscreen, restarting my computer, -windowed -resx 800 -resy 600 -winx 800 -winy 600. Nothing works. Please help me out.

Update: I even tried reinstalling the game. No luck.

https://mega.nz/file/q5oi2SqC#6WGjIt_T_14C31ebJpR94UmWvkSnphLRdory8qfZAks

You’ll need to provide crash dumps as well.
Here’s a guide how:

2 Likes

Bump

I’m having the same issue. Shortly after launching the game, a message box pops up saying “The UE4-Tower Game has crashed and will… Fatal error!” Oddly, the game works in the background and if I move the box to the side I can get to the main menu. Here is a link for my crash dump:
https://mega.nz/file/1VABUYjA#qwnLFcOmJgSN1qbRCHEzVpKpI25_CXnnqj3P20rqcQ8

1 Like

This is exactly what happens to me! I did some digging and found it was related to agc_lib.dll in <installation>\Steam\steamapps\common\Tower Unite\Tower\Binaries\Win64. Looking at the crash dump you sent, it’s the same problem I have.

1 Like

Found another thread talking about this: Fatal Error Repeating

Given that the crash happens when you start the game and that the error message was “The thread tried to read from or write to a virtual address for which it does not have the appropriate access.”

The system has become unable to read and write information to the section of the temporary memory, there are a bunch of different things that could cause it.
Your antivirus denied the game the permission to read and write to the memory.
The RAM modules could have suffered some sort of damage or fault, or the ram slots themselves have become damaged.
It’s unlikely but sectors on your storage device can have become corrupted and thus cannot be written to or read from.

There are other possible causes but they seem unlikely since you would have more problems than just being unable to play tower unite.

For the antivirus:
Go into your antivirus program and tell it to ignore what tower unite is doing while it’s running.

For the faulty RAM slots:
Turn off the pc and swap the RAM modules into unused slots

For the faulty RAM:
Enter the search field in the windows start menu and type in Windows Memory Diagnostic, or open the Run.exe program and type in mdsched.exe.
Then just click “restart now and check for problems”

For the storage devices:
Open the CMD as an administrator and type chkdsk : /f /r
driveletter is the letter for whatever storage device you wanna check, for example: P:

I’m having the same issue relating to agc_lib.dll

Crash dump: https://www.dropbox.com/s/pjfjqbx2lt7djh4/UE4Minidump.dmp?dl=0

It would definitely not be the agc, the agc just handles your units, randomly generated prices and a few other things.

The modules section in the crash dump is merely saying what systems and files that the game was using at the time of the crash

You can’t say it definitely isn’t the agc - it’s the faulting module, it’s at least related or could be.

As for your suggestions:

There is no antivirus enabled.

My RAM slots are not faulty.

My RAM is not faulty.

My storage device is not corrupt.

Any other ideas?

Same here. Antivirus is allowing the app to go through its firewall, RAM slots and RAM is not faulty, and storage is clean.

Did a small bit of digging.

Running Tower.exe from the Tower Unite installation folder triggers a fatal error message. However running in <Installation>\Tower\Binaries\Win64 allows you to get a bit further, only kicking you out because you aren’t running from Steam.

Question for those affected. What Windows OS are you using? For me, It’s Windows 10 Insider Build.

Also running Windows 10 Insider Preview. Build 20150.1000

I’d highly recommend anyone using Insider builds to revert back to the retail builds of Windows 10. I’ve tested Insider Build 20152.1000 and immediately was faced with this issue, the problem has gone away since reverting back to the public Retail Build 19041.331 of Windows 10.

3 Likes

I don’t know what this or what that means. I have a clean install of Windows

Here is the Memory Diagnostic from the laptop just now:


And the chkdsk /c /f






It says that it made corrections to the file system so I ran it again, no errors so I didn’t run it again





I checked my Norton on both computers, and it has no barriers to TU–all completely open.

I can’t reply to Jai but I don’t have either of those builds of Windows he stated

Here is the Memory Diagnostics from my Desktop (the kernel error is for Skype):




Ran the cmd chkdsk /c /f and it corrected errors so I am running it again





Ran it again and it is saying no errors so didn’t run it again





Just to re-iterate: I do not have either build Jai mentioned. And I really don’t want to have to re-load 837GB of client files in order to go back on the build version in order to play this game.




As far as I can tell (based on the Microsoft website https://insider.windows.com/en-us/getting-started/) I don’t[?] have the Windows Insider, but that doesn’t necessarily mean that the build that came out on Update Tuesday might not be messing with things.

Windows Insider is essentially a beta build for windows, you can test upcoming updates before they come out. We had though people experiencing this crash were all using Windows Insider, which led us to believe it was an issue on Windows’s end, not ours.

If you’re certain you’re not using this I’ll re-open the investigation. This might mean we have to send out a new build of a library, as this crash happens in a library that’s hardly ever changed and unfortunately doesn’t have debug information (this is what allows us to see what’s going in a crash dump). Then we can collect meaningful crash dumps and hopefully track down the issue.

Thanks for your patience by the way, I saw you went through some effort to verify your machine was in working order.

3 Likes

Thank you guys with your patience with us lol I’m not trying to be a bother (I swear)–I’m just hoping to help you guys nail it down. I really want to see this game succeed.