[0.8.7.0] Non-interactable NPCs

I’m actually unsure as to why this could be happening, but I’ve placed down 3 NPCs in the past 30 minutes. They are all edited, and they are intractable as intended. I went to place down another NPC and it is completely uninteractable. I can’t speak with it, no matter what I change the model to. I’ve tried all the default NPCs, and some workshop ones. No luck. I restarted the condo with no luck, and restarted the game with no luck.

Interesting to note that the copycat tool fixes the issue of it being uninteractable, however placing down new NPCs still doesn’t work.

The NPC characters need some dialogue lines before you can interact with them
1 of said lines are enough to make them interactable

Ah yes, you are correct. I could have sworn i was able to interact with them even without dialogue though previously, unless that was just my imagination, or unless that got updated?

It was updated. I made them only interactive if they have dialogue because otherwise you’d just be talking to many NPCs who have nothing to say. I encountered a lot of people using NPCs as props and no dialogue so I felt there was no point to talk to blank dialogue props.

6 Likes