[] Unable to equip wearables

I cannot equip any hats or glasses, basically anything for my player model over the last couple days. I can however change my golf and bowling balls which are in almost the same menus.

Not sure if this has ever happened to anyone else I tried the game in DX11 and DX10 and tried to equip and unequip everything as well as change and reset player models and tried different servers. When I try to edit my appearance in the main menu as well it won’t add any hats.

Notes / Media

please ignore discord chatter in the background and the end of the clip. first minute or so shows issues with appearance and shows it in game

Anyone find a fix for this yet? It makes me wanna quit the game i miss my hats :*(

Try going to the following folder for your Tower install and deleting the Wearables.dat file.

./steamapps/common/Tower Unite/Tower/ClientPlayerData2/

A not too uncommon thing is to have either your Hotbar.dat or EquipHotbar.dat files just sorta die and stop working, which prevents you using the slots. The fix for those is usually just deleting their files, so I’d try doing the same thing with Wearables.dat since that’s the one that holds which appearance items you’re wearing.

The Upgrades for Golf and Bowling are saved in a different way, being in the Game.ini config folder, so that’s why those still work, probably.

1 Like