[] Water Clean now invisible/perfectly clear

As of the current update, the “Water Clean” texture has become almost entirely clear, as opposed to the shiny water with animated ripples in the water.

Steps to Reproduce

Apply the Water Clean texture to any canvas wall (haven’t tested with other primitives but I’d assumed it’s the same there)

What I expected to happen

To have nice looking water in my ponds and pool

What happened

The water was entirely or almost entirely invisible.

Notes / Media

Here’s what the water looks like right now:

I can also attest.


I thought something changed, but I couldn’t be sure. Glad to know I’m not crazy.
On the flipside, I think Water Dark may have gotten slightly more opaque in some maps.

1 Like

they weren’t kidding about the “clean” part…

in all seriousness this is definitely annoying :<

I’ll take a look into what changed, don’t think the shader had any modifications on purpose.


This is now fixed in the next update.


This issue is still apparent in, but now it looks different.

(these 2 screenshots are taken in DirectX 10)
There’s now a weird animated texture that I looks like a bunch of blurry dots moving around erratically.
(This one is taken in DirectX 11. It still doesn’t look the way it did prior to

EDIT: For reference, here’s how it looked prior to (just got these from a friend, not the clearest images but I feel they help paint a better picture. Water is in the background in the second image)

Not the biggest of concerns, but I’d just like to re-bump this, in case it’s something that could be an easy fix. The fix that was implemented never brought back the original appearance, and I’ve just started building again, only to remember that this water texture is still broken.

1 Like

I guess I can’t speak for you, but I definitely considered it fixed for a while now.

(this one has a dark backdrop than my last screen)

Odd. That looks completely different from how it looks for me. It still looks completely flat, almost entirely clear and has blurry, transparent dots moving around it.

This is all in DX10, but it used to look like shiny clear water with gentle waves on the surface, even in DX10 before 0.14

Ah, I’m 100% in dx11 with max settings. That could be it?

I’ll have to try in DX11 again sometime, but back when this fix was first rolled out, I tried both DX10 and DX11 and it looked wrong in different ways in both versions.

It’s kinda hard to tell but the texture seems a bit more clear in DX10 than DX11.

This is how it looks in DX11:

And DX10:

That’s so weird. That’s how it’s supposed to look, but for me and at least 2 friends, it looks messed up and broken.

I’m gonna verify my game and try out some different graphics options maybe.

Alright so: My findings are leaving me feeling a little silly! As it turns out, with my Effects video setting at medium, it just looks completely wrong. On high, it looks exactly as it’s supposed to. I could’ve sworn I’d tried that at some point, but apparently not?

Oh well. At least I’ve figured that out, major apologies for wasting everyone’s time LOL